home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / gnome-base / gnome-vfs-2.12.2 / gnome-vfs-2.12.2.ebuild < prev    next >
Text File  |  2006-05-01  |  2KB  |  89 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.12.2.ebuild,v 1.10 2006/02/03 19:34:34 agriffis Exp $
  4.  
  5. inherit eutils gnome2
  6.  
  7. DESCRIPTION="Gnome Virtual Filesystem"
  8. HOMEPAGE="http://www.gnome.org/"
  9. LICENSE="GPL-2 LGPL-2"
  10.  
  11. SLOT="2"
  12. KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
  13. IUSE="doc gnutls hal howl ipv6 samba ssl"
  14.  
  15. RDEPEND=">=gnome-base/libbonobo-2.3.1
  16.     >=gnome-base/gconf-1.2
  17.     >=dev-libs/glib-2.6
  18.     >=gnome-base/orbit-2.12.4
  19.     >=dev-libs/libxml2-2.6
  20.     app-arch/bzip2
  21.     virtual/fam
  22.     gnome-base/gnome-mime-data
  23.     >=x11-misc/shared-mime-info-0.14
  24.     dev-libs/popt
  25.     samba? ( >=net-fs/samba-3 )
  26.     ssl? (
  27.         >=dev-libs/openssl-0.9.5
  28.         !gnome-extra/gnome-vfs-sftp )
  29.     gnutls? (
  30.         !ssl? (
  31.             net-libs/gnutls
  32.             !gnome-extra/gnome-vfs-sftp ) )
  33.     hal? (
  34.         >=sys-apps/hal-0.5
  35.         >=sys-apps/dbus-0.32
  36.         sys-apps/pmount )
  37.     howl? ( >=net-misc/howl-0.9.6-r1 )"
  38.  
  39. # ssl/gnutls USE deps : if both are enabled choose openssl
  40. # foser <foser@gentoo.org> 19 Apr 2004
  41.  
  42. DEPEND="${RDEPEND}
  43.     >=dev-util/intltool-0.29
  44.     >=dev-util/pkgconfig-0.9
  45.     doc? ( >=dev-util/gtk-doc-1 )"
  46.  
  47. DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
  48. USE_DESTDIR="1"
  49.  
  50.  
  51. pkg_setup() {
  52.     G2CONF="--disable-schemas-install \
  53.         $(use_enable ssl openssl) \
  54.         $(use_enable gnutls)      \
  55.         $(use_enable samba)       \
  56.         $(use_enable ipv6)        \
  57.         $(use_enable hal)         \
  58.         $(use_enable howl)"
  59.  
  60.     if use hal; then
  61.         G2CONF="${G2CONF} --with-hal-mount=/usr/bin/pmount-hal \
  62.             --with-hal-umount=/usr/bin/pumount \
  63.             --with-hal-eject=/usr/bin/eject"
  64.     fi
  65.  
  66.     # this works because of the order of conifgure parsing
  67.     # so should always be behind the use_enable options
  68.     # foser <foser@gentoo.org 19 Apr 2004
  69.     use gnutls && use ssl && G2CONF="${G2CONF} --disable-gnutls"
  70. }
  71.  
  72. src_unpack() {
  73.     unpack "${A}"
  74.     cd "${S}"
  75.  
  76.     epatch ${FILESDIR}/${PN}-2.11.92-fbsd.patch
  77.     # Allow the Trash on afs filesystems (#106118)
  78.     epatch ${FILESDIR}/${PN}-2.12.0-afs.patch
  79.  
  80.     autoconf || die "autoconf failed"
  81. }
  82.  
  83. src_install() {
  84.     gnome2_src_install
  85.  
  86.     # remove unused dir (#46567)
  87.     rmdir ${D}/usr/doc
  88. }
  89.